Hjelp til install og config av AMP i Ubuntu?

Kategori overført fra Linux1

Hjelp til install og config av AMP i Ubuntu?

Innleggav _Ferrari_ » man 30.04.2007 23:11

Hei!

Jeg trenger en teskje guide til hvordan man skal gå frem for å få opp Apache, PHP og MySQL i Ubuntu fungerende. Skal også ha php-cli. Poenget er at jeg skal kjøre dedicated server i Trackmania, med Aseco, en "bot" som benytter seg av PHP, og som lagrer rekorder i en MySQL database. Problemet mitt er at jeg ikke får opp AMP skikkelig. Ønsker meg derfor en teskjeguide, som kan hjelpe meg.
medlem i 155 måneder
 

Innleggav Smjor » tir 01.05.2007 8:46


Brukerens avatar
medlem i 159 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 15:15

Takker, men det oppstår et problem under install av MySQL...
Kode: Merk alt
larserik@server:~$ sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql
Leser pakkelister ... Ferdig
Skaper oversikt over avhengighetsforhold ... Ferdig
mysql-server er allerede nyeste versjon.
libapache2-mod-auth-mysql er allerede nyeste versjon.
php5-mysql er allerede nyeste versjon.
0 oppgraderte, 0 nylig installerte, 0 å fjerne og 40 ikke oppgradert.
2 pakker ikke fullt installert eller fjernet.
MÃ¥ hente 0B med arkiver.
Etter utpakking vil 0B ekstra diskplass bli brukt.
Setter opp mysql-server-5.0 (5.0.22-0ubuntu6.06.3) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
/etc/init.d/mysql: line 100: /etc/mysql/debian-start: No such file or directory
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: Feil ved behandling av mysql-server-5.0 (--configure):
 underprosessen post-installation script returnerte feilstatus 1
dpkg: Kravproblem hindrer oppsettet av mysql-server:
 mysql-server krever mysql-server-5.0. Men:
  Pakken mysql-server-5.0 er ikke satt opp ennÃ¥.
dpkg: Feil ved behandling av mysql-server (--configure):
 kravproblem - setter ikke opp pakken
Det oppsto feil ved behandling av:
 mysql-server-5.0
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
medlem i 155 måneder
 

Innleggav ak » tir 01.05.2007 15:48

Det ser ut som om du tidligere har stoppet prosessen midt under installasjon av mysql, eller at du har en pakkekilde som sender deg tull.

Prøv
sudo dpkg -r mysql-server

?

Eventuelt
sudo dpkg --force-all -r mysql-server

Administrator
Brukerens avatar
medlem i 184 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 21:48

Får opp akkurat samme melding etter å ha kjørt kommandoen du gav meg der..

Forresten, så er ikke PHP5 integrert i Apache heller. Noen innstillinger jeg må forandre på? PHP filen jeg har laget for å teste vises ikke i nettleser når jeg åpner localhost, den bare lastes ned..
medlem i 155 måneder
 

Innleggav geirendre » tir 01.05.2007 21:58

Du må åpne for php i configfila til Apache, hvis du ikke har gjort det.
http://www.debianhelp.co.uk/apache2.htm
http://www.debianhelp.co.uk/webserver.htm
:-)

Erfaren
Brukerens avatar
medlem i 178 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 22:44

Får ikke til det der. Guiden for PHP5 lager jo bare symlinker som ikke peker noe sted..
medlem i 155 måneder
 

Innleggav lilminime » tir 01.05.2007 22:47

1. "sudo apt-get --purge remove mysql-server apache2 php5" - uten ""-tegnene
2 "sudo apt-get install mysql-server apache2 php5 mysql-php5 php-cli"
been there, done that :)
medlem i 160 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 22:53

Nei, det fungerte ikke... Samme problem hva php angår gitt.. Vurderer å bare ta en reinstall, og innstallere Ubuntu LAMP server. Da vil det fungere ut av boksen?
medlem i 155 måneder
 

Innleggav ak » tir 01.05.2007 22:57

Yap, det bør fungere. Jeg vet ikke hvordan du fikk en så skrudd installasjon av MySQL

Administrator
Brukerens avatar
medlem i 184 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 22:59

Konkluderer med at, når du ikke vet, vet ingen :p Jeg får ta meg tid til en reinstall en dag skjønner jeg. Trenger jo til syvende og sist ikke Gnome, når jeg allikevel stort sett jobber via terminalen.
medlem i 155 måneder
 

Innleggav ak » tir 01.05.2007 23:02

Den konklusjonen er på tynn is, men det tar ikke lang tid å reinstallere.

Ta en titt på https://help.ubuntu.com/6.10/ubuntu/ser ... index.html når du kommer opp på andre siden, 7.04 er neppe særlig annerledes.

Administrator
Brukerens avatar
medlem i 184 måneder
 

Innleggav _Ferrari_ » tir 01.05.2007 23:19

By default, the Apache 2 Web server is configured to run PHP5 scripts. In other words, the PHP5 module is enabled in Apache2 Web server automatically when you install the module. Please verify if the files /etc/apache2/mods-enabled/php5.conf and /etc/apache2/mods-enabled/php5.load exist. If they do not exists, you can enable the module using a2enmod command.


De filene finnes ikke... Og kommer følgelig ikke frem når jeg kjører a2enmod. Har innstallert libapache2-mod-php5

Blir nok en reinstall her gitt...
medlem i 155 måneder
 

Innleggav _Ferrari_ » man 11.06.2007 0:45

Har nå lagt inn Ubuntu LAMP server. Da fungerte alt supert rett ut fra boksen. Eneste jeg måtte gjøre var å innstallere PHP-cli, og "uncomment" mysql i configen PHP-cli. Nå fungerer alt utmerket!
medlem i 155 måneder
 

Re: Hjelp til install og config av AMP i Ubuntu?

Innleggav Blå-tann » lør 12.01.2008 22:06

Enkleste måte er dog: Xampp.com
Du må bare herde den litt, anvisninger finnes i webinterface
medlem i 145 måneder
 


Returner til Utvikling i Linux



Hvem er i Forumene

Registrerte brukere: Google [Bot]



cron